apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 54322] New: 'apu-1-config --includes' is mistake
Date Mon, 17 Dec 2012 21:03:35 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=54322

            Bug ID: 54322
           Summary: 'apu-1-config --includes' is mistake
           Product: APR
           Version: HEAD
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: APR-util
          Assignee: bugs@apr.apache.org
          Reporter: sbt79@mail.ru
    Classification: Unclassified

Created attachment 29776
  --> https://issues.apache.org/bugzilla/attachment.cgi?id=29776&action=edit
apr-util.tar.gz

When I tried to build the 'subversion 1.7.7', I had the following mistakes:
---
./configure
...
config.status: creating subversion/svn_private_config.h.tmp
config.status: executing libtool commands
config.status: executing svn_private_config.h.tmp commands
configure: WARNING: we have configured without BDB filesystem support   <---


You don't seem to have Berkeley DB version 4.0.14 or newer
installed and linked to APR-UTIL.  We have created Makefile which will build
Subversion without support for the Berkeley DB back-end.  You can find the
latest version of Berkeley DB here:
  http://www.oracle.com/technology/software/products/berkeley-db/index.html
-----
---
[serg@de78ab subversion-1.7.7]$ make
/bin/sh /home/serg/job/subversion-build/subversion-1.7.7/libtool --tag=CC
--silent --mode=compile gcc -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE
-D_LARGEFILE64_SOURCE  -g -O2   -pthread  -D_LARGEFILE64_SOURCE -DNE_LFS
-Werror=implicit-function-declaration  -I./subversion/include -I./subversion
-I/usr/include/apr-1   -I/usr/include/apr-1 /include -I/usr/include/neon   -o
subversion/libsvn_delta/cancel.lo -c subversion/libsvn_delta/cancel.c
gcc: /include: No such file or directory
make: *** [subversion/libsvn_delta/cancel.lo] Error 1
-----

Then I found that the 'apu-1-config 1.5.1' utility showed next:
---
[serg@de78ab ~]$ apu-1-config --includes
 -I/usr/include/apr-1 /include
-----

The next patch helped me:
---
diff -ru a/apu-config.in b/apu-config.in
--- a/apu-config.in 2010-09-29 18:21:25.000000000 +0400
+++ b/apu-config.in 2012-12-18 00:19:08.000000000 +0400
@@ -88,7 +88,7 @@

     LIBS=`echo "$LIBS" | sed -e "s $APU_BUILD_DIR/xml/expat $prefix g" -e "s
$prefix/libexpat.la -lexpat g"`
     LDFLAGS=`echo "$LDFLAGS" | sed -e "s $APU_BUILD_DIR/xml/expat $prefix g"`
-    INCLUDES=`echo "$INCLUDES" | sed -e "s $APU_BUILD_DIR/xml/expat $prefix g"
-e "s -I$prefix/lib  g"`
+    INCLUDES=`echo "$INCLUDES" | sed -e "s $APU_BUILD_DIR/xml/expat $prefix
g"`
 else
     LA_FILE="$APU_BUILD_DIR/lib${APRUTIL_LIBNAME}.la"
 fi
-----
Sorry, I don't know why 's#-I$prefix/lib##g" is needed here, but it was broken
all.

Maybe I am mistaken.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@apr.apache.org
For additional commands, e-mail: bugs-help@apr.apache.org


Mime
View raw message