apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 53263] New: rpmbuild fails with "nss native error -8128: (SEC_ERROR_NO_MODULE)"
Date Fri, 18 May 2012 18:59:20 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=53263

          Priority: P2
            Bug ID: 53263
          Assignee: bugs@apr.apache.org
           Summary: rpmbuild fails with "nss native error -8128:
                    (SEC_ERROR_NO_MODULE)"
          Severity: normal
    Classification: Unclassified
                OS: Linux
          Reporter: NWoodward@the-connection.com
          Hardware: PC
            Status: NEW
           Version: 1.4.1
         Component: APR-util
           Product: APR

Overview:

When building apr-util 1.4.1 on CentOS 5 using the spec file included in the
distribution tarball, the build fails.

Steps to Reproduce:

Download and extract the latest apr-util tarball.
rpmbuild -ba apr-util.spec

Actual Results:

The build fails with this output:

...
testmd4             : SUCCESS
testmd5             : SUCCESS
testcrypto          : |passphrase: KEY_3DES_192/MODE_CBC nss native error
-8128:
  (SEC_ERROR_NO_MODULE)
-passphrase: KEY_3DES_192/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE
)
|passphrase: KEY_AES_256/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
-passphrase: KEY_AES_256/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
|passphrase: KEY_AES_256/MODE_ECB nss native error -8128: 
(SEC_ERROR_NO_MODULE)
-passphrase: KEY_AES_256/MODE_ECB nss native error -8128: 
(SEC_ERROR_NO_MODULE)
|passphrase: KEY_AES_192/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
-passphrase: KEY_AES_192/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
|passphrase: KEY_AES_192/MODE_ECB nss native error -8128: 
(SEC_ERROR_NO_MODULE)
-passphrase: KEY_AES_192/MODE_ECB nss native error -8128: 
(SEC_ERROR_NO_MODULE)
|passphrase: KEY_AES_128/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
-passphrase: KEY_AES_128/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
|passphrase: KEY_AES_128/MODE_ECB nss native error -8128: 
(SEC_ERROR_NO_MODULE)
-passphrase: KEY_AES_128/MODE_ECB nss native error -8128: 
(SEC_ERROR_NO_MODULE)
/passphrase: KEY_3DES_192/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE
)
|passphrase: KEY_3DES_192/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE
)
/passphrase: KEY_AES_256/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
|passphrase: KEY_AES_256/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
/passphrase: KEY_AES_192/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
|passphrase: KEY_AES_192/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
/passphrase: KEY_AES_128/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
|passphrase: KEY_AES_128/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
-passphrase: KEY_3DES_192/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE
)
-passphrase: KEY_AES_256/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
-passphrase: KEY_AES_256/MODE_ECB nss native error -8128: 
(SEC_ERROR_NO_MODULE)
|passphrase: KEY_3DES_192/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE
)
|passphrase: KEY_AES_256/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
|passphrase: KEY_3DES_192/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE
)
|passphrase: KEY_AES_256/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
|passphrase: KEY_AES_256/MODE_ECB nss native error -8128: 
(SEC_ERROR_NO_MODULE)
\passphrase: KEY_3DES_192/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE
)
\passphrase: KEY_AES_256/MODE_CBC nss native error -8128: 
(SEC_ERROR_NO_MODULE)
FAILED 6 of 13
testldap            : SUCCESS
testdbd             : SUCCESS
...

Expected Results:

The build succeeds and creates an rpm.

Build Date & Platform:

Build 2012-05-28 on CentOS 5.8


Additional Details:

This apparently occurs during the `make check` portion of the build. The only
reference to this issue I could find is
http://mail-archives.apache.org/mod_mbox/apr-dev/201112.mbox/%3C4EE50935.9010502@kippdata.de%3E,
and no solution was forthcoming there.

I'd like to know what I can do to address CVE-2012-0883 while this bug exists.
As I understand it, that vulnerability was fixed in apache 2.4.2, which
requires a recent version of apr-util.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message