apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 52813] New: buildconf on AIX fails when using apr and apr-util out of trunk, succeeds when using 1.4.6 and 1.4.1
Date Fri, 02 Mar 2012 17:07:45 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=52813

             Bug #: 52813
           Summary: buildconf on AIX fails when using apr and apr-util out
                    of trunk, succeeds when using 1.4.6 and 1.4.1
           Product: APR
           Version: HEAD
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: APR-util
        AssignedTo: bugs@apr.apache.org
        ReportedBy: mamfelt@gmail.com
    Classification: Unclassified


buildconf fails to build a valid configure. Instead configure ends with
configure: error: APR-util not found.

replication:

download apr, apr-util and httpd-trunk using svn

in httpd-trunk run

# ./buildconf
found apr source: ../apr
copying build files
rebuilding include/ap_config_auto.h.in
rebuilding configure
rebuilding rpm spec file
fixing timestamps for ap_expr sources
root@x103:[/data/prj/TEST/httpd-trunk]build/aix/buildaix.ksh                    
+ ./configure 
                --enable-layout=AIX 
                --with-apr=/opt/bin/apr-1-config 
                --with-apr-util=/opt/bin/apu-1-config 
                --enable-mpms-shared=all 
                --enable-mods-shared=all 
                --disable-lua > build/aix/configure.out
configure: error: APR-util not found.  Please read the documentation.
./configure returned an error
root@x103:[/data/prj/TEST/httpd-trunk]
========================================

compare with:

root@x103:[/data/prj/TEST/httpd-trunk]./buildconf
--with-apr=/data/prj/apr-1.4.6 --with-apr-util=/data/prj/apr-util-1.4.1
found apr source: /data/prj/apr-1.4.6
found apr-util source: /data/prj/apr-util-1.4.1
copying build files
rebuilding include/ap_config_auto.h.in
rebuilding configure
rebuilding rpm spec file
fixing timestamps for ap_expr sources
root@x103:[/data/prj/TEST/httpd-trunk]build/aix/buildaix.ksh                    
+ ./configure 
                --enable-layout=AIX 
                --with-apr=/opt/bin/apr-1-config 
                --with-apr-util=/opt/bin/apu-1-config 
                --enable-mpms-shared=all 
                --enable-mods-shared=all 
                --disable-lua > build/aix/configure.out
configure: WARNING: apr/apr-util is compiled without ldap support
configure: WARNING: apr/apr-util is compiled without ldap support
+ make > build/aix/make.out
==============================

Note: to replicate you need to know ALL the files that a successful buildconf
creates (and/or a successful ./configure) because to repeat/verify this I had
download the httpd-trunk again

i.e. mv httpd-trunk httpd-x
svn checkout http://svn.apache.org/repos/asf/httpd/httpd/trunk httpd-trunk
cd httpd-trunk
./buildconf

Once successful, the error does not occur!

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@apr.apache.org
For additional commands, e-mail: bugs-help@apr.apache.org


Mime
View raw message