apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 48905] New: server processes hang with threaded apache
Date Sat, 13 Mar 2010 09:37:41 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=48905

           Summary: server processes hang with threaded apache
           Product: APR
           Version: HEAD
          Platform: PC
        OS/Version: Solaris
            Status: NEW
          Severity: major
          Priority: P2
         Component: APR
        AssignedTo: bugs@apr.apache.org
        ReportedBy: remko@initworks.com


On busy sites we see server processes hang with state WWWWWWWWWW etc by
checking apache with server-status. The processes will consume an entire core
and will not reset to a normal state. 

We can only kill the process with kill -9 pid. The server still keeps running
and accepting new connections.

Sometimes a core file appears:

08047b5c 0xfdb5e000(fe7a0420, 2)
08047b84 ld.so.1`purge_exit_handlers+0xcc(feffb28c, fe7a0080)
08047be8 ld.so.1`remove_hdl+0x756(fe7f0490, fefc0e70, 0)
08047c04 ld.so.1`dlclose_core+0xb1(fe7f0490, fefc0e70)
08047c20 ld.so.1`dlclose_intn+0x21(fe7f0490, fefc0e70)
08047c38 ld.so.1`dlclose_check+0x2a(fe7f0490, fefc0e70)
08047c58 ld.so.1`dlclose+0x38(fe7f0490, fe199070, 0, fec3e77a)
08047c78 libapr-1.so.0.3.12`dso_cleanup+0x24(8166df8, 80c6818, 8047cb8,
fec4413a, feae0318, 80be838)
08047cb8 libapr-1.so.0.3.12`apr_pool_destroy+0x89(80c4810, 0, f4240, fec4413a,
fe7f4c78, 0)
08047cf8 libapr-1.so.0.3.12`apr_pool_destroy+0x61(80c2808, 0, 82f5f68, 80b5ee0,
80c6708, 80b9554)
08047d28 destroy_and_exit_process+0x2d(feffdd58, fea65aa0, feffb33c, feffb818,
80b6d0c, 80b6d0c)
08047df8 main+0x9ce(8047df0, feffb818, 8047e28)
08047e28 _start+0x5d(3, 8047ec8, 8047ee9, 8047eec, 0, 8047ef2)

changing MaxRequestsPerChild  to 0 or 10000 does not appear to make a
difference. 

Lower traffic windows , eg. during nights and weekends when requests drop to
~25 per sec, do not produce any hanging server processes. 

we can reproduce this only on production boxes where this problem appears every
hour or so.

a busy system: around 100 req/s and 4gb/h
both 32 and 64bit show this problem

apache 2.2.14
apr 1.3.12, also tested with > 1.3.3

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@apr.apache.org
For additional commands, e-mail: bugs-help@apr.apache.org


Mime
View raw message