apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 45515] New: mod_session_* from httpd 2.3.0-dev doesn't compile with SSL and current (stable and development) releases of apr and apr-util
Date Thu, 31 Jul 2008 12:14:22 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=45515

           Summary: mod_session_* from httpd 2.3.0-dev doesn't compile with
                    SSL and current (stable and development) releases of apr
                    and apr-util
           Product: APR
           Version: HEAD
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: APR
        AssignedTo: bugs@apr.apache.org
        ReportedBy: michal@rulez.pl
                CC: bugs@httpd.apache.org


Dear All,

I'm trying to compile an httpd-2.3.0-dev with mod_auth_form and SSL. It uses
mod_session_*. During compilation I see there is a problem with some include
files from apr and apr-util (no matter - last stable release - at time of
writing both have version 1.3.2). 

But from the beginning. 

1) I use ./buildconf to create all necessary configure files. 
httpd was taken from svn.apache.org using following command :

svn co http://svn.apache.org/repos/asf/httpd/httpd/trunk httpd-trunk 
Its SVN revision is 681340. 

I don't have separate apr and apr-utils, so I've put them into
httpd-trunk/srclib/apr and httpd-trunk/srclib/apr-util - apr and apr-util taken
from SVN (or taken from stabsvn co le release (at time of writing - 1.3.2) - no
matter, which source it is. 

Let's say, we are using current versions from SVN :
svn co http://svn.apache.org/repos/asf/apr/apr/trunk srclib/apr
Its revision is 681340

svn co http://svn.apache.org/repos/asf/apr/apr/trunk srclib/apr

configure phase works ok. 
My configure line is : 
./configure --prefix=/usr/local/apache23-new --enable-http --enable-info
--enable-authn-dbd --enable-authz-dbd --enable-dbd --enable-cache
--enable-disk-cache --enable-mem-cache --enable-charset-lite --enable-proxy
--enable-proxy-ajp --enable-ssl --enable-vhost-alias --enable-so
--enable-rewrite --enable-speling --enable-mods-shared=all --with-included-apr
--with-pgsql=/usr/local --enable-session --enable-session-crypto
--enable-session-cookie --enable-session-dbd

During make phase I see following error : 

mod_session_crypto.c:20:66: apr_ssl.h: No such file or directory
mod_session_crypto.c:60: error: syntax error before "apr_evp_factory_t"
mod_session_crypto.c: In function `crypt_init':
mod_session_crypto.c:64: error: `conf' undeclared (first use in this function)
mod_session_crypto.c:64: error: (Each undeclared identifier is reported only
once
mod_session_crypto.c:64: error: for each function it appears in.)
mod_session_crypto.c:65: error: `r' undeclared (first use in this function)
mod_session_crypto.c:73: error: `key' undeclared (first use in this function)
mod_session_crypto.c:73: error: `APR_EVP_KEY_PUBLIC' undeclared (first use in
this function)
mod_session_crypto.c:74: error: `f' undeclared (first use in this function)
mod_session_crypto.c:76: error: `APR_EVP_FACTORY_ASYM' undeclared (first use in
this function)
mod_session_crypto.c:84: error: `APR_EVP_KEY_SYM' undeclared (first use in this
function)
mod_session_crypto.c:87: error: `APR_EVP_FACTORY_SYM' undeclared (first use in
this function)
mod_session_crypto.c: In function `encrypt_string':
mod_session_crypto.c:133: error: `apr_evp_factory_t' undeclared (first use in
this function)
mod_session_crypto.c:133: error: `f' undeclared (first use in this function)
mod_session_crypto.c:134: error: `apr_evp_crypt_t' undeclared (first use in
this function)
mod_session_crypto.c:134: error: `e' undeclared (first use in this function)
mod_session_crypto.c:135: error: syntax error before "key"
mod_session_crypto.c:148: error: `key' undeclared (first use in this function)
mod_session_crypto.c:153: error: `APR_EVP_ENCRYPT' undeclared (first use in
this function)
mod_session_crypto.c: In function `decrypt_string':
mod_session_crypto.c:208: error: `apr_evp_factory_t' undeclared (first use in
this function)
mod_session_crypto.c:208: error: `f' undeclared (first use in this function)
mod_session_crypto.c:209: error: `apr_evp_crypt_t' undeclared (first use in
this function)
mod_session_crypto.c:209: error: `e' undeclared (first use in this function)
mod_session_crypto.c:210: error: syntax error before "key"
mod_session_crypto.c:216: error: `key' undeclared (first use in this function)
mod_session_crypto.c:221: error: `APR_EVP_DECRYPT' undeclared (first use in
this function)
*** Error code 1

It seems, there is a lack of apr_ssl.h in current release. I was searching
previous SVN releases and it looks like this file was removed around 40000
revisions ago. Old file taken from older of apr releases of apr cause httpd to
compile, but there are some symbol errors hard to reproduce in this bug report.

Sincerely,

Michal Zapalski


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@apr.apache.org
For additional commands, e-mail: bugs-help@apr.apache.org


Mime
View raw message