apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 45320] New: apr-util-1.3. 2 fails to build with --disable-util-dso
Date Tue, 01 Jul 2008 23:05:15 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=45320

           Summary: apr-util-1.3.2 fails to build with --disable-util-dso
           Product: APR
           Version: HEAD
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: APR-util
        AssignedTo: bugs@apr.apache.org
        ReportedBy: alanh@fairlite.co.uk


When specifying the option --disable-util-dso and apr-1.3.2 has been built with
--disable-dso the apr-util-1.3.2 build fails with this....

/bin/sh /usr/bin/libtool --silent --mode=compile 
gcc   -O2 -pipe -fomit-frame-pointer -DHAVE_CONFIG_H -D_GNU_SOURCE   -Iinclude 
 -Iinclude/private  -I/usr/include/apr-1  -o misc/apu_dso.lo -c 
misc/apu_dso.c && touch misc/apu_dso.lo
misc/apu_dso.c:105: error: expected ')' before '*' token
make[1]: *** [misc/apu_dso.lo] Error 1

It's because at line 105 we have ....

apr_status_t apu_dso_load(apr_dso_handle_sym_t *dsoptr, const char *module,
                          const char *modsym, apr_pool_t *pool)

and apr_dso_handle_sym_t isn't defined when apr-1.3.2 is build with
--disable-dso as it's wrapped up in apr_dso.h which doesn't define this type
unless APR_HAS_DSO is defined, 
so the build fails.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@apr.apache.org
For additional commands, e-mail: bugs-help@apr.apache.org


Mime
View raw message