apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 43345] New: - --with-expat=xml/expat broken in configure
Date Mon, 10 Sep 2007 18:48:41 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=43345>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=43345

           Summary: --with-expat=xml/expat broken in configure
           Product: APR
           Version: HEAD
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: APR-util
        AssignedTo: bugs@apr.apache.org
        ReportedBy: rainer.jung@kippdata.de


The apr-util bundled with Apache httpd 2.2.6 changed behaviour for the
--with-expat switch of configure. Previously it was allowed to use
--with-expat=xml/expat to compile the bundled expat, now only
--with-expat=builtin does this.

The change was done in r493791 as a fix to BZ
http://issues.apache.org/bugzilla/show_bug.cgi?id=28205.

Strictly speaking it is nowhere documented, that a value of xml/expat should be
used for building with the internal version, but it worked like this for a long
time, and still is the most logical interpretation of this value.

Problem analysis: in file apr-util/build/apu-conf.m4 there is now:

    125 AC_DEFUN([APU_FIND_EXPAT], [
    126
    127 apu_has_expat=0
    128
    129 # Default: will use either external or bundled expat.
    130 apu_try_external_expat=1
    131 apu_try_builtin_expat=1

OK, we allow building with builtin expat

    132
    133 AC_ARG_WITH([expat],
    134 [  --with-expat=DIR        specify Expat location, or 'builtin'], [
    135   if test "$withval" = "yes"; then
    136     AC_MSG_ERROR([a directory must be specified for --with-expat])
    137   elif test "$withval" = "no"; then
    138     AC_MSG_ERROR([Expat cannot be disabled (at this time)])
    139   elif test "$withval" = "builtin"; then
    140     apu_try_external_expat=0
    141   else

if we gave a path to configure, like xml/expat, we get into this part

    142     # Add given path to standard search paths if appropriate:
    143     if test "$withval" != "/usr"; then
    144       APR_ADDTO(LDFLAGS, [-L$withval/lib])
    145       APR_ADDTO(CPPFLAGS, [-I$withval/include])
    146       APR_ADDTO(APRUTIL_INCLUDES, [-I$withval/include])
    147     fi
    148     # ...and refuse to fall back on the builtin expat.
    149     apu_try_builtin_expat=0

and we disable use of the builtin variant.

    150   fi
    151 ])
    152

I think, apu_try_builtin_expat should only be set to "0", if withval is !=
"xml/expat". Possible patch would be:

--- build/apu-conf.m4.orig      2007-09-10 13:00:21.000000000 +0200
+++ build/apu-conf.m4   2007-09-10 20:36:46.000000000 +0200
@@ -146,7 +146,11 @@
       APR_ADDTO(APRUTIL_INCLUDES, [-I$withval/include])
     fi
     # ...and refuse to fall back on the builtin expat.
-    apu_try_builtin_expat=0
+    if test "$withval" != "xml/expat"; then
+      apu_try_builtin_expat=0
+    else
+      apu_try_external_expat=0
+    fi
   fi
 ])

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@apr.apache.org
For additional commands, e-mail: bugs-help@apr.apache.org


Mime
View raw message