apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41348] New: - APR_POLL_LASTDESC isn't marked as deprecated
Date Thu, 11 Jan 2007 13:19:00 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41348>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41348

           Summary: APR_POLL_LASTDESC isn't marked as deprecated
           Product: APR
           Version: HEAD
          Platform: All
        OS/Version: other
            Status: NEW
          Keywords: PatchAvailable
          Severity: trivial
          Priority: P5
         Component: APR
        AssignedTo: bugs@apr.apache.org
        ReportedBy: lucian.grijincu@avira.com


<quote> fom
http://mail-archives.apache.org/mod_mbox/apr-dev/200207.mbox/raw/%3c029701c22521$00e2fea0$0a01230a@KOJ%3e
"BTW, I should also mention that the APR_POLL_LASTDESC enum is only there
for backwards compat.  Most code that uses apr_poll would never use that
enum."
</quote>

Marking it as deprecated explicitly in the API doc would be best.
aka something of the following sort:
-    APR_POLL_LASTDESC           /**< descriptor is the last one in the list */
+    APR_POLL_LASTDESC           /**< descriptor is the last one in the list
(here only for backwards compatibility, should not be used) */

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@apr.apache.org
For additional commands, e-mail: bugs-help@apr.apache.org


Mime
View raw message