apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 40559] New: - problem building apr on solaris
Date Wed, 20 Sep 2006 20:08:13 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=40559>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=40559

           Summary: problem building apr on solaris
           Product: APR
           Version: 1.2.7
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: normal
          Priority: P2
         Component: APR
        AssignedTo: bugs@apr.apache.org
        ReportedBy: zaniyah@gmail.com


Apologies if you've seen this problem before, but I was unable to find it
elsewhere so I'm sending it to you guys (see below).  I would really
appreciate some help with this.

BTW I couldn't find the link to bugzilla on the apr project home page, so
originally submitted it to the bugs@apr.apache.org list directly.  It would be
helpful if the reject message could give the bugzilla url (and if the project
menu could include a link to it).  It took some effort to find this site.

Thanks

Jess

I'm trying to build apr-1.2.7, but there are warnings when running
configure and when I later run make, it refuses to build altogether.  I tried to
build 0.9.x (whichever is currently listed in the downloads) but that also gave
up with the same error.

The warnings when I run configure are similar to this one (I will attach the
output of stderr and stdout in the next post):

checking arpa/inet.h presence... yes
configure: WARNING: arpa/inet.h: present but cannot be compiled
configure: WARNING: arpa/inet.h:     check for missing prerequisite headers?
configure: WARNING: arpa/inet.h: see the Autoconf documentation
configure: WARNING: arpa/inet.h:     section "Present But Cannot Be Compiled"
configure: WARNING: arpa/inet.h: proceeding with the preprocessor's result
configure: WARNING: arpa/inet.h: in the future, the compiler will take
precedence
configure: WARNING:     ## ------------------------------------------ ##
configure: WARNING:     ## Report this to the AC_PACKAGE_NAME lists.  ##
configure: WARNING:     ## ------------------------------------------ ##

The error I see when I run make is:

 >make
/bin/bash /home/jessj/APR/unix/apr-1.2.7/libtool --silent
--mode=compile gcc -g -O2 -pthreads   -DHAVE_CONFIG_H -DSOLARIS2=9
-D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -D_LARGEFILE64_SOURCE
-I./include -I/home/jessj/APR/unix/apr-1.2.7/include/arch/unix
-I./include/arch/unix -I/home/jessj/APR/unix/apr-1.2.7/include  -o
passwd/apr_getpass.lo -c passwd/apr_getpass.c && touch
passwd/apr_getpass.lo
In file included from /usr/include/netinet/in.h:41,
                from /usr/include/sys/socket.h:203,
                from include/apr.h:117,
                from include/apr_pools.h:37,
                from
/home/jessj/APR/unix/apr-1.2.7/include/arch/apr_private_common.h:24,
                from
/home/jessj/APR/unix/apr-1.2.7/include/arch/unix/apr_private.h:779,
                from passwd/apr_getpass.c:22:
/usr/include/sys/stream.h:307: parse error before "projid_t"
*** Error code 1
make: Fatal error: Command failed for target `passwd/apr_getpass.lo'
Current working directory /home/jessj/APR/unix/apr-1.2.7
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'

FYI:

>uname -a
SunOS neptune 5.9 Generic_118558-19 sun4u sparc SUNW,Sun-Fire-V240

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

Mime
View raw message