apex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ambarish Pande <ambarish.pande2...@gmail.com>
Subject Re: Mapreduce Job History server not running.
Date Sun, 04 Sep 2016 05:40:45 GMT
Hello ,

I have not used eclipse for running it. I am deploying the jar using the
hadoop jar command.

Thank You.

On 03-Sep-2016 1:40 am, "Sairam Kannan" <skannan5@hawk.iit.edu> wrote:

> HI Ambarish,
>                               Are you running your program from the
> Eclipse client in the remote machine or executing as a jar file from the
> master. Because running from the Eclipse client will run in an Local
> (LocalJobRunner) mode by default and you need to explicitly specify the
> resource configuration "mapreduce.framework.name = yarn". If your job is
> running in a local mode, the job will not be shown in the WebUI. Can you
> paste your logs for better understanding ?.
>
> Thanks and Regards,
> Sairam Kannan
>
> On Fri, Sep 2, 2016 at 2:48 PM, Ambarish Pande <
> ambarish.pande2011@gmail.com> wrote:
>
>> Hello Ma'am,
>>
>> I started the jobhistory server. Now it shows the web UI but still it is
>> not showing any jobs that I am running. I tried running the Pi and
>> Wordcount example, but still it does not show up on the UI.
>>
>> Thank You.
>>
>>
>> On Fri, Sep 2, 2016 at 2:43 PM, Priyanka Gugale <priyanka@datatorrent.com
>> > wrote:
>>
>>> Hi Ambarish,
>>>
>>> Normally port 8088 is for ResourceManager web interface. On this port
>>> you can see currently running container status.
>>> For history server default port is 19888. The history server needs to be
>>> running. Use "/mr-jobhistory-daemon.sh" from your hadoop installation to
>>> start historyserver.
>>>
>>> For reference, this
>>> <http://www.michael-noll.com/tutorials/running-hadoop-on-ubuntu-linux-multi-node-cluster/>
>>> is a good block to refer to setup your multinode cluster.
>>>
>>> -Priyanka
>>>
>>> On Thu, Sep 1, 2016 at 7:50 PM, Ambarish Pande <
>>> ambarish.pande2011@gmail.com> wrote:
>>>
>>>> Hello Guys,
>>>>
>>>> I have setup a 3 node hadoop cluster successfully. It successfully runs
>>>> a MapReduce job. Problem is the WEB UI for MapReduce Job History server is
>>>> not running. Whenever I try http://master:198888 nothing shows up.
>>>>
>>>> Or is there any other way to see running applications through a web ui.
>>>> I Tried http://master:8088 but it also does not show any Map Reduce
>>>> applications running.
>>>>
>>>> What must be the probelm?. What am i doing wrong?
>>>>
>>>> Thank You in Advance.
>>>>
>>>>
>>>>
>>>
>>
>

Mime
View raw message