apex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Templeton <ryan_temple...@yahoo.com>
Subject Re: Minimum development environment
Date Tue, 05 Apr 2016 18:50:32 GMT
Thanks Sandesh!
Worked like a champ. I actually downloaded the Hadoop 2.6 flavor from the other reference
in the thread. Simply unzipped it and added HADOOP_HOME to my env settings. Restarted Eclipse
and the test runs as expected. 

    On Tuesday, April 5, 2016 2:10 PM, Sandesh Hegde <sandesh@datatorrent.com> wrote:
 

 Hello Ryan,
I don't have Windows machine to try, Can you please try out the following step ?http://stackoverflow.com/questions/19620642/failed-to-locate-the-winutils-binary-in-the-hadoop-binary-path
ThanksSandesh

On Tue, Apr 5, 2016 at 10:21 AM Ryan Templeton <ryan_templeton@yahoo.com> wrote:

Hey guys,
I am wondering what the minimum environment I need to develop and test my Apex apps?
Running in Eclipse on Windows, I generated Apex project using the Apex archtype  and tried
to run the default JUnit test that gets created but get the following error:
2016-04-05 13:00:02,677 [main] DEBUG physical.PhysicalPlan initCheckpoint - Writing activation
checkpoint {ffffffffffffffff, 0, 0} PTOperator[id=1,name=randomGenerator] RandomNumberGenerator{name=null}2016-04-05
13:00:02,697 [main] ERROR util.Shell getWinUtilsPath - Failed to locate the winutils binary
in the hadoop binary pathjava.io.IOException: Could not locate executable null\bin\winutils.exe
in the Hadoop binaries. at org.apache.hadoop.util.Shell.getQualifiedBinPath(Shell.java:278)
at org.apache.hadoop.util.Shell.getWinUtilsPath(Shell.java:300) at org.apache.hadoop.util.Shell.<clinit>(Shell.java:293)
at org.apache.hadoop.fs.RawLocalFileSystem.setPermission(RawLocalFileSystem.java:639) at org.apache.hadoop.fs.RawLocalFileSystem.create(RawLocalFileSystem.java:305)

What else do I need to have installed to get a dev environment up and running? Is Hadoop required
for JUnit tests like this?
Thanks,Ryan


  
Mime
View raw message