apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (APEXCORE-605) Suppress bootstrap compiler warning
Date Mon, 09 Jan 2017 17:26:58 GMT

    [ https://issues.apache.org/jira/browse/APEXCORE-605?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15812314#comment-15812314
] 

ASF GitHub Bot commented on APEXCORE-605:
-----------------------------------------

GitHub user vrozov opened a pull request:

    https://github.com/apache/apex-core/pull/444

    APEXCORE-605 Suppress bootstrap compiler warning

    @tweise Please review

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/vrozov/apex-core APEXCORE-605

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/apex-core/pull/444.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #444
    
----
commit ec0f137154d128800c47aaac6f02434a098419c0
Author: Vlad Rozov <v.rozov@datatorrent.com>
Date:   2017-01-09T17:25:10Z

    APEXCORE-605 Suppress bootstrap compiler warning

----


> Suppress bootstrap compiler warning
> -----------------------------------
>
>                 Key: APEXCORE-605
>                 URL: https://issues.apache.org/jira/browse/APEXCORE-605
>             Project: Apache Apex Core
>          Issue Type: Improvement
>            Reporter: Vlad Rozov
>            Assignee: Vlad Rozov
>            Priority: Minor
>
> Apex uses animal-sniffer-maven-plugin to enforce 1.7 API compatibility. The following
warning caused by {{<source>1.7</source>}} compiler plugin option should be suppressed.
> {noformat}
> [WARNING] bootstrap class path not set in conjunction with -source 1.7
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message