apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sandesh (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (APEXCORE-550) User friendly error message when Java version mismatch happens
Date Wed, 05 Oct 2016 21:47:20 GMT

     [ https://issues.apache.org/jira/browse/APEXCORE-550?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sandesh reassigned APEXCORE-550:
--------------------------------

    Assignee: Sandesh

> User friendly error message when Java version mismatch happens
> --------------------------------------------------------------
>
>                 Key: APEXCORE-550
>                 URL: https://issues.apache.org/jira/browse/APEXCORE-550
>             Project: Apache Apex Core
>          Issue Type: Bug
>            Reporter: Sandesh
>            Assignee: Sandesh
>
> When an app package is compiled with Java 1.8 and Apex is using 1.7, we see the following
behaviour with Apex CLI
> 1. launch <AppPackage>
>     "No applications in Application Package", ideally it should point out the exact error
message
> 2. get-app-package-operators <AppPackage>
> Throws the following exception java.lang.UnsupportedClassVersionError, 
> Should we add an extra message indicating that the Java version mismatch has happened?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message