apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pramod Immaneni (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (APEXCORE-548) ApexCLI does not correctly detect running applications with the same name at launch time
Date Wed, 05 Oct 2016 22:26:20 GMT

    [ https://issues.apache.org/jira/browse/APEXCORE-548?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15550141#comment-15550141
] 

Pramod Immaneni commented on APEXCORE-548:
------------------------------------------

I was thinking about that approach but where I saw a problem was that in the property files
it is possible to have multiple app names with different configurations for the same app.
Would we have separate app factory entries for each of them?

> ApexCLI does not correctly detect running applications with the same name at launch time
> ----------------------------------------------------------------------------------------
>
>                 Key: APEXCORE-548
>                 URL: https://issues.apache.org/jira/browse/APEXCORE-548
>             Project: Apache Apex Core
>          Issue Type: Bug
>            Reporter: David Yan
>            Assignee: David Yan
>
> ApexCli is incorrectly using the fully qualified class name of the Application class
instead of the name given in the ApplicationAnnotation when trying to make sure no running
application bears the same name.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message