apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Weise (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (APEXCORE-536) Upgrade Hadoop dependency
Date Thu, 15 Sep 2016 15:37:20 GMT

    [ https://issues.apache.org/jira/browse/APEXCORE-536?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15493691#comment-15493691
] 

Thomas Weise commented on APEXCORE-536:
---------------------------------------

We do have to worry about backward compatibility. I think it is safe to move to 2.6 but this
is important enough of a change to discuss and take a vote.  


> Upgrade Hadoop dependency
> -------------------------
>
>                 Key: APEXCORE-536
>                 URL: https://issues.apache.org/jira/browse/APEXCORE-536
>             Project: Apache Apex Core
>          Issue Type: Improvement
>            Reporter: Thomas Weise
>              Labels: roadmap
>
> Currently Apex depends on Hadoop 2.2 and runs on all later 2.x version. Hadoop 2.2 is
quite old, most Apex users have more recent Hadoop installs. Latest distro releases are based
on 2.6 and 2.7. There are several important features that were added in Hadoop since 2.2 that
Apex should be able to leverage.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message