apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (APEXCORE-516) StramLocalCluster should always use loopback address for buffer server location
Date Mon, 29 Aug 2016 18:19:21 GMT

    [ https://issues.apache.org/jira/browse/APEXCORE-516?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15446637#comment-15446637
] 

ASF GitHub Bot commented on APEXCORE-516:
-----------------------------------------

GitHub user vrozov opened a pull request:

    https://github.com/apache/apex-core/pull/376

    APEXCORE-516 - StramLocalCluster should always use loopback address for buffer server
location

    @tweise Please review

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/vrozov/apex-core APEXCORE-516

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/apex-core/pull/376.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #376
    
----

----


> StramLocalCluster should always use loopback address for buffer server location
> -------------------------------------------------------------------------------
>
>                 Key: APEXCORE-516
>                 URL: https://issues.apache.org/jira/browse/APEXCORE-516
>             Project: Apache Apex Core
>          Issue Type: Improvement
>         Environment: Jenkins Apache (builds.apache.org using beam label)
>            Reporter: Vlad Rozov
>            Assignee: Vlad Rozov
>            Priority: Minor
>
> With incorrectly configured environments where InetAddress.getLocalHost() returns resolvable
address, but that address is not among active interfaces of the host where buffer server is
deployed, neither buffer server publish or subscriber will be able to connect to the buffer
server. In most cases, this issue should be solved by properly configuring the cluster or
node where buffer server is deployed. This fix should address only a case where Apex is deployed
into an automatically provisioned environment for running unit and integration tests.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message