apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pramod Immaneni (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (APEXCORE-483) Dependency to httpclient version 3.5 causing problem with newer versions of Hadoop
Date Sun, 10 Jul 2016 01:39:11 GMT

    [ https://issues.apache.org/jira/browse/APEXCORE-483?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15369382#comment-15369382
] 

Pramod Immaneni commented on APEXCORE-483:
------------------------------------------

To get this around the problem we will shade the artifact in the engine.

> Dependency to httpclient version 3.5 causing problem with newer versions of Hadoop
> ----------------------------------------------------------------------------------
>
>                 Key: APEXCORE-483
>                 URL: https://issues.apache.org/jira/browse/APEXCORE-483
>             Project: Apache Apex Core
>          Issue Type: Bug
>            Reporter: Pramod Immaneni
>            Assignee: Pramod Immaneni
>
> Engine uses artifact org.apache.httpcomponents:httpclient:4.3.5 for kerberos SPNEGO related
functionality. This artifact does not appear as a transitive dependency anywhere in the dependency
tree including dependencies of hadoop 2.2.0, the hadoop version we build against. However
newer versions of hadoop are including an earlier version of the above artifact version 4.2.5
in the classpath that does not have the necessary functionality. This results in multiple
versions of the artifact to getting included in the classpath at runtime causing runtime exceptions.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message