apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pramod Immaneni (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (APEXCORE-448) Make operator name available in OperatorContext
Date Sat, 23 Jul 2016 14:35:20 GMT

    [ https://issues.apache.org/jira/browse/APEXCORE-448?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15390707#comment-15390707

Pramod Immaneni commented on APEXCORE-448:

There is another attribute of such read-only ilk, IS_OUTPUT_UNIFIED on PortContext. The read-only
behavior is not enforced by the platform but user changing it has no effect. However, in this
case, it might be confusing for user to see a method in DAG to add operator with a name and
an operator attribute NAME. How about calling the method getOperatorName() to be more specific.
Do you want to propose it on dev or would you like me to?

> Make operator name available in OperatorContext
> -----------------------------------------------
>                 Key: APEXCORE-448
>                 URL: https://issues.apache.org/jira/browse/APEXCORE-448
>             Project: Apache Apex Core
>          Issue Type: Improvement
>            Reporter: Chandni Singh
>            Assignee: Chandni Singh
> Need name of the logical operator in the OperatorContext which can be used by WindowDataManager
to create a unique path per logical operator .

This message was sent by Atlassian JIRA

View raw message