apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Weise (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (APEXCORE-475) change the YARN_APPLICATION_TYPE from DataTorrent to ApacheApex
Date Sat, 25 Jun 2016 20:14:37 GMT

    [ https://issues.apache.org/jira/browse/APEXCORE-475?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15349768#comment-15349768
] 

Thomas Weise commented on APEXCORE-475:
---------------------------------------

The suggestion from [~davidyan] is backward compatible. The newer Apex client will be able
for access older apps. The scenario you are bringing up is actually one of forward compatibility
and I don't think that was ever discussed or advertised. Also I think that practical relevance
of the scenario is limited, most users will use the CLI that they used to launch the app to
also manage it. Finally... to me this does not look like a pressing issue, is this based on
user feedback?

> change the YARN_APPLICATION_TYPE from DataTorrent to ApacheApex
> ---------------------------------------------------------------
>
>                 Key: APEXCORE-475
>                 URL: https://issues.apache.org/jira/browse/APEXCORE-475
>             Project: Apache Apex Core
>          Issue Type: Improvement
>    Affects Versions: 4.0.0
>            Reporter: Sandesh
>            Priority: Minor
>
> This change is backward incompatible to do in the minor release, as that is also used
to identify Apex applications.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message