apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Weise <tho...@datatorrent.com>
Subject Re: Compilation error while updating dependency to malhar 3.4.0
Date Fri, 03 Jun 2016 14:26:16 GMT
The 3.4.0 release isn't backward compatible due to the security related
change in core. So this was an opportunity to clean up this confusion also.
You are right that since this operator wasn't evolving, we should have
listed it in the release notes.

--
sent from mobile
On Jun 3, 2016 7:11 AM, "Sandeep Deshmukh" <sandeep@datatorrent.com> wrote:

> Hi All,
>
> We had developed an application using  AbstractKafkaInputOperator from
> Malhar 3.2.0-incubator. We are planning to upgrade to Malhar 3.4.0. While
> recompiling our code, we observed that the compilation fails due to
> backward incompatible change in the AbstractKafkaInputOperator. The
> AbstractKafkaInputOperator is not marked as Evolving. The error is:
>
> *cannot find symbol*
> *symbol:   variable idempotentStorageManager*
>
> We found out that https://issues.apache.org/jira/browse/APEXMALHAR-2093
> changed usage of IdempotentStorageManager to WindowDataManager. The
> backward incompatible change was documented in the pull request.
>
> How should we handle this issue?
>
> [1]
>
> https://github.com/apache/incubator-apex-core/blob/master/docs/compatibility.md
>
> Regards,
> Sandeep
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message