apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sandesh (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (APEXCORE-386) Upgrade to Jackson 1.9.13
Date Wed, 04 May 2016 22:57:13 GMT

    [ https://issues.apache.org/jira/browse/APEXCORE-386?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15271588#comment-15271588
] 

Sandesh commented on APEXCORE-386:
----------------------------------

Apex supports Hadoop 2.2, which has a dependency on Jackson 1.8.8. Until the supported Hadoop
version changes, we won't be able to upgrade.

> Upgrade to Jackson 1.9.13
> -------------------------
>
>                 Key: APEXCORE-386
>                 URL: https://issues.apache.org/jira/browse/APEXCORE-386
>             Project: Apache Apex Core
>          Issue Type: Improvement
>    Affects Versions: 3.3.0
>            Reporter: Tatu Saloranta
>            Priority: Minor
>
> Looks like current version of Apex core depends on Jackson 1.9.2. There are much more
recent patches, latest being 1.9.13. It would make sense to upgrade to that to avoid problems
fixed with the patches; most OSS libraries that rely on Jackson 1.x rely on that version (like
hadoop-core, avro)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message