apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Yan <da...@datatorrent.com>
Subject Backward compatibility note in Apex between 3.3.0 and 3.4.0
Date Fri, 06 May 2016 00:49:37 GMT
Hi all,

With the imminent release of Apex Core 3.4.0, I'd like to bring up some
backward compatibility issues between Apex 3.3.x and 3.4.x:

- Because we needed to fix an important security issue of a 3rd party
library that we use, Apex apps that use WebSockeInputOperator and
WebSocketOutputOperator or any derivative of these two classes for 3.3.x or
below will need to recompile against the upcoming Apex Malhar 3.4.0 to run
on Apex Core 3.4.x.

- The OperatorContext interface has a new method
getWindowsFromCheckpoint(). This mostly affects Malhar unit tests.  This
should likely not affect existing users.

There is a PR open in Apex Malhar that is directly related to the above two
issues: https://github.com/apache/incubator-apex-malhar/pull/258

Please let me know if you have questions about this.

Thanks,

David

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message