apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ganelin, Ilya" <Ilya.Gane...@capitalone.com>
Subject Re: PROPOSAL: Renaming "Module" to "CompositeOperator"
Date Tue, 03 May 2016 17:14:08 GMT
Why not rename Module to SubGraph? CompositeOperator is a rather unwieldy term - there’s
already some pretty hefty operator names in Malhar :)



On 5/3/16, 9:47 AM, "Amol Kekre" <amol@datatorrent.com> wrote:

>This is good time to make the change as the api is evolving and does not
>have a widespread adoption. I would prefer to simply change it too.
>
>Thks
>Amol
>
>
>On Tue, May 3, 2016 at 9:12 AM, David Yan <david@datatorrent.com> wrote:
>
>> Hi Pramod,
>>
>> The existing Module class is marked "InterfaceStability.Evolving" and
>> therefore we don't guarantee backward compatibility. Also there are
>> probably very very few users, if any, who use any class derived from the
>> current Module because of the recent introduction of the concept.
>>
>> I think at this point if we decide to go forward with the change,
>> deprecating "Module" for backward compatibility is an overkill.
>>
>> David
>>
>> On Mon, May 2, 2016 at 10:55 PM, Pramod Immaneni <pramod@datatorrent.com>
>> wrote:
>>
>> > I don't think we should rename Module to CompositeOperator as it will
>> break
>> > backwards compatibility. If this is something we want to go forward with
>> > then we should think about depreacting Module.
>> >
>> > Thanks
>> >
>> > On Mon, May 2, 2016 at 10:46 PM, Tushar Gosavi <tushar@datatorrent.com>
>> > wrote:
>> >
>> > > +1
>> > >
>> > > I have a pull request #313 opened for Module related work. I will do
>> > > following changes to incorporate this suggestion.
>> > >
>> > > - Rename Module to CompositeOperator
>> > > - Rename Vertex in DAG to GenerticOperator
>> > >
>> > > Do we also need to change the rest API to reflex the name change? The
>> > only
>> > > change required is in logicalPlan with includeModules parameter. It
>> > > includes a "modules" field
>> > > in the json. this field can be changed to "compositeOperators". Let me
>> > know
>> > > your
>> > > thought on this?
>> > >
>> > > Regards,
>> > > -Tushar.
>> > >
>> > >
>> > >
>> > > On Tue, May 3, 2016 at 10:35 AM, Amol Kekre <amol@datatorrent.com>
>> > wrote:
>> > >
>> > > > The packaging has been taken up by other names, module is now a java
>> > only
>> > > > construct.
>> > > >
>> > > > Thks,
>> > > > Amol
>> > > >
>> > > >
>> > > > On Mon, May 2, 2016 at 8:15 PM, Sandesh Hegde <
>> sandesh@datatorrent.com
>> > >
>> > > > wrote:
>> > > >
>> > > > > Earlier the vision was, module can contain widgets/UI along with
>> the
>> > > > > operators. So it made sense to have that name.
>> > > > > If that is not the case then +1 for CompositeOperator
>> > > > >
>> > > > > On Mon, May 2, 2016 at 7:53 PM Amol Kekre <amol@datatorrent.com>
>> > > wrote:
>> > > > >
>> > > > > > Good point. +1
>> > > > > >
>> > > > > > Thks
>> > > > > > Amol
>> > > > > >
>> > > > > >
>> > > > > > On Mon, May 2, 2016 at 6:17 PM, Sasha Parfenov <
>> sashap@apache.org>
>> > > > > wrote:
>> > > > > >
>> > > > > > > +1.
>> > > > > > >
>> > > > > > > Everybody is already familiar with concept of an Operators
in
>> > Apex.
>> > > > It
>> > > > > > is
>> > > > > > > best to keep that terminology, and use CompositeOperator
to
>> > > indicate
>> > > > > they
>> > > > > > > related to Operators, rather than introduce a new concept
of
>> > > Modules.
>> > > > > > >
>> > > > > > > This will also have a significant impact on documentation,
>> where
>> > > word
>> > > > > > > Operator can continue to serve interchangeably for
Operator or
>> > > > > > > CompositeOperator, instead of always having to say
"Operators
>> and
>> > > > > > Modules".
>> > > > > > >
>> > > > > > > Thanks,
>> > > > > > > Sasha
>> > > > > > >
>> > > > > > >
>> > > > > > >
>> > > > > > > On Mon, May 2, 2016 at 4:10 PM, David Yan <
>> david@datatorrent.com
>> > >
>> > > > > wrote:
>> > > > > > >
>> > > > > > > > Hi all,
>> > > > > > > >
>> > > > > > > > From the javadoc of com.datatorrent.api.Module
in Apex Core:
>> > > > > > > >
>> > > > > > > > A Module is a component which can be added to
the DAG similar
>> > to
>> > > > the
>> > > > > > > > operator, using addModule API. The module should
implement
>> > > > > populateDAG
>> > > > > > > > method, which will be called by the platform,
and DAG
>> populated
>> > > by
>> > > > > the
>> > > > > > > > module will be replaced in place of the module.
>> > > > > > > >
>> > > > > > > > However, the word "module" is very overloaded,
and it is too
>> > > > abstract
>> > > > > > and
>> > > > > > > > general to describe the concept. The same term
is also used
>> by
>> > > > maven
>> > > > > > for
>> > > > > > > > example.
>> > > > > > > >
>> > > > > > > > Since the interface is marked "Evolving" and because
of the
>> > > recent
>> > > > > > > > introduction, there are very few users using it
if any, I
>> would
>> > > > like
>> > > > > to
>> > > > > > > > propose that we change the name "Module" to
>> > "CompositeOperator".
>> > > > > > > >
>> > > > > > > > Please share your opinion. Thanks!
>> > > > > > > >
>> > > > > > > > David
>> > > > > > > >
>> > > > > > >
>> > > > > >
>> > > > >
>> > > >
>> > >
>> >
>>
________________________________________________________

The information contained in this e-mail is confidential and/or proprietary to Capital One
and/or its affiliates and may only be used solely in performance of work or services for Capital
One. The information transmitted herewith is intended only for use by the individual or entity
to which it is addressed. If the reader of this message is not the intended recipient, you
are hereby notified that any review, retransmission, dissemination, distribution, copying
or other use of, or taking of any action in reliance upon this information is strictly prohibited.
If you have received this communication in error, please contact the sender and delete the
material from your computer.
Mime
View raw message