apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yogi Devendra (JIRA)" <j...@apache.org>
Subject [jira] [Created] (APEXCORE-378) nomenclature change for APPLICATION_WINDOW_COUNT
Date Mon, 07 Mar 2016 11:29:40 GMT
Yogi Devendra created APEXCORE-378:
--------------------------------------

             Summary: nomenclature change for APPLICATION_WINDOW_COUNT
                 Key: APEXCORE-378
                 URL: https://issues.apache.org/jira/browse/APEXCORE-378
             Project: Apache Apex Core
          Issue Type: Improvement
            Reporter: Yogi Devendra
            Priority: Minor


Attribute APPLICATION_WINDOW_COUNT from OperatorContext should have better name.

Because:
1. From the name it looks like a attribute of the APPLICATION; but actually it is an Operator
attribute.
2. It is very confusing to say that APPLICATION_WINDOW_COUNT can be different for different
Operators within an Application.  

Can we have some better name for this attribute? 
Any suggestions for the new name? 
I propose following names:
1. OPERATOR_WINDOW_COUNT
2. OPERATOR_WINDOW_SPAN



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message