apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Isha Arkatkar <i...@datatorrent.com>
Subject Re: Naming: STRAM and StreamingContainer
Date Tue, 08 Mar 2016 00:29:53 GMT
+1 for Apex App Master, and Apex Worker

We have a few other classes with StreamingContainer prefix e.g.
StreamingContainerManager, StreamingContainerAgent. Should we consider
renaming these as well?

Thanks,
Isha

On Mon, Mar 7, 2016 at 4:12 PM, Chandni Singh <chandni@datatorrent.com>
wrote:

> Isn't operator the entity that performs the actual work/task?
>
> I don't think so. Operator is an abstraction for business logic. It is not
> the class with the main method. The main class here is the
> StreamingContainer which will executes the business logic provided in the
> operator.
>
> Chandni
>
> On Mon, Mar 7, 2016 at 3:58 PM, Ashwin Chandra Putta <
> ashwinchandrap@gmail.com> wrote:
>
> > Isn't operator the entity that performs the actual work/task? From what I
> > know, the StreamingContainer is more of a handler of operators within the
> > container.
> >
> > Regards,
> > Ashwin.
> >
> > On Mon, Mar 7, 2016 at 3:26 PM, Chandni Singh <chandni@datatorrent.com>
> > wrote:
> >
> > > How about calling StreamingContainer as
> > ApexWorkerHandler/ApexWorkerManager
> > > as it is possible that there can be multiple operators within a
> container
> > > and each operator by itself is a worker.
> > >
> > >  IMO an operator is not a worker. At least we haven't been calling it a
> > > 'Worker' so far.
> > > Apex worker corresponds to a child container and can run multiple
> > operators
> > > if that is the case.
> > >
> > > Chandni
> > >
> > >
> > > On Mon, Mar 7, 2016 at 3:20 PM, Ashwin Chandra Putta <
> > > ashwinchandrap@gmail.com> wrote:
> > >
> > > > +1 for ApexAppMaster.
> > > >
> > > > How about calling StreamingContainer as
> > > ApexWorkerHandler/ApexWorkerManager
> > > > as it is possible that there can be multiple operators within a
> > container
> > > > and each operator by itself is a worker.
> > > >
> > > > Regards,
> > > > Ashwin.
> > > >
> > > > On Mon, Mar 7, 2016 at 2:51 PM, David Yan <david@datatorrent.com>
> > wrote:
> > > >
> > > > > +1 for "Apex Worker".
> > > > >
> > > > > On Mon, Mar 7, 2016 at 2:17 PM, Chandni Singh <
> > chandni@datatorrent.com
> > > >
> > > > > wrote:
> > > > >
> > > > > > How about renaming them to Apex App Master, and Apex Worker
> > > Container?
> > > > > > I think just Apex Worker is sufficient if we make this change.
> > > > > >
> > > > > >
> > > > > > On Mon, Mar 7, 2016 at 2:14 PM, Thomas Weise <
> > thomas@datatorrent.com
> > > >
> > > > > > wrote:
> > > > > >
> > > > > > > I like the suggestion. Can we record it in JIRA for the
next
> > major
> > > > > > release?
> > > > > > >
> > > > > > > On Mon, Mar 7, 2016 at 1:52 PM, David Yan <
> david@datatorrent.com
> > >
> > > > > wrote:
> > > > > > >
> > > > > > > > Today, in both our doc and our code, we use the name
STRAM
> > > > (STReaming
> > > > > > App
> > > > > > > > Master) for the App Master, and StreamingContainer
> (previously
> > > > known
> > > > > as
> > > > > > > > StramChild) for the worker containers.
> > > > > > > >
> > > > > > > > But since STRAM is running in a container itself,
calling the
> > > > worker
> > > > > > > > containers StreamingContainer is not exactly ideal.
> > > > > > > >
> > > > > > > > How about renaming them to Apex App Master, and Apex
Worker
> > > > > Container?
> > > > > > > > Thoughts?
> > > > > > > >
> > > > > > > > David
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > > >
> > > >
> > > > --
> > > >
> > > > Regards,
> > > > Ashwin.
> > > >
> > >
> >
> >
> >
> > --
> >
> > Regards,
> > Ashwin.
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message