apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Weise <tho...@datatorrent.com>
Subject Re: nomenclature change for APPLICATION_WINDOW_COUNT
Date Thu, 03 Mar 2016 16:46:55 GMT

This is a good suggestion. We should change it in the next major release.

Perhaps we can open a JIRA that we can use to list this and similar items
so they are not forgotten.

With respect to windowing in general we should look into expanding from the
current processing time based approach. We support event time in several
operators. We can look at Beam and Flink to broaden this.


On Thu, Mar 3, 2016 at 4:32 AM, Yogi Devendra <yogidevendra@apache.org>

> Hi,
> I studied source code, docs related to windowing for my presentation on
> "Windowing in Apex".
> After going through the phase of learning, teaching apex windowing concepts
> to others; I realized that attribute APPLICATION_WINDOW_COUNT from
> OperatorContext should have better name.
> Because:
> 1. From the name it looks like a attribute of the APPLICATION; but actually
> it is an Operator attribute.
> 2. It is very confusing to say that APPLICATION_WINDOW_COUNT can be
> different for different Operators within an Application.
> Can we have some better name for this attribute?
> Any suggestions for the new name?
> I propose following names:
> I understand that, introducing new name to the existing attribute might
> break backward compatibility. But, we can deal with that by deprecating the
> older name and keeping it alive till next major release.
> What is your opinion on this?
> ~ Yogi

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message