apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yogi Devendra <yogideven...@apache.org>
Subject Naming sugestion for HDFS output modules
Date Wed, 23 Mar 2016 11:19:11 GMT

Currently, I am in the process of developing HDFS output module:
We have two modules for HDFS output.
1. Tuple based []
2. File based (used for file copy)

Currently, I am calling #1 as "HDFS output module" as this module is the
one which will be mostly used to write tuples to HDFS.

I am calling #2 as "HDFS file copy module"; because it is mainly used only
for file copy operations.

Any suggestions for alternate names for these modules?
>From the names we want to stress the following

   - #2 to be used only for file copy operations (block by block copy)
   - #1 to be used for tuple by tuple write to HDFS
   - Both #1 and #2 are HDFS output modules.

Actually, we thought of combining them into single module. But, problem is
port signatures for both the modules is different. Thus, combing them will
result in different ports based on configuration.
It would be confusing for the app developers to decide which ports should I
connect to if ports are changing based on the configuration.


1. Name suggestion for #1?
a. HDFS output module b. HDFSTuplesWriteModule c. HDFSMsgBasedOutputModule
d. other (please specify)

2. Name suggestion for #2?
a. HDFS file copy module b. HDFSBlocksWriteModule c. HDFSBlockBasedOutputModule
d.  HDFSFileCopyOutputModule e. other (please specify)

~ Yogi

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message