apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pramod Immaneni <pra...@datatorrent.com>
Subject Re: regarding error while launching application
Date Sat, 05 Dec 2015 00:15:51 GMT
Hi Venkat,

Looks like you have a mismatch between the apex version you compiled you
app against vs the apex version you are launching the application against.
Can you check that.

Pramod

On Fri, Dec 4, 2015 at 11:56 AM, Kottapalli, Venkatesh <
VKottapalli@directv.com> wrote:

> The below is the stack trace.
>
>
> java.lang.NoClassDefFoundError: com/datatorrent/api/BaseOperator
>         at java.lang.ClassLoader.defineClass1(Native Method)
>         at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
>         at
> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
>         at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
>         at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
>         at
> java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:789)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
>         at java.lang.ClassLoader.defineClass1(Native Method)
>         at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
>         at
> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
>         at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
>         at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
>         at
> java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:789)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
>         at com.directv.sms.app.PPVFlow.populateDAG(PPVFlow.java:46)
>         at
> com.datatorrent.stram.plan.logical.LogicalPlanConfiguration.prepareDAG(LogicalPlanConfiguration.java:1191)
>         at
> com.datatorrent.stram.client.StramAppLauncher$1.createApp(StramAppLauncher.java:404)
>         at
> com.datatorrent.stram.client.StramAppLauncher.launchApp(StramAppLauncher.java:479)
>         at
> com.datatorrent.stram.cli.DTCli$LaunchCommand.execute(DTCli.java:2044)
>         at
> com.datatorrent.stram.cli.DTCli.launchAppPackage(DTCli.java:3454)
>         at com.datatorrent.stram.cli.DTCli.access$7000(DTCli.java:103)
>         at
> com.datatorrent.stram.cli.DTCli$LaunchCommand.execute(DTCli.java:1889)
>         at com.datatorrent.stram.cli.DTCli$3.run(DTCli.java:1446)
> Caused by: java.lang.ClassNotFoundException:
> com.datatorrent.api.BaseOperator
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
>         at
> java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:789)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
>
> regards,
> Venkatesh.
>
> -----Original Message-----
> From: Kottapalli, Venkatesh [mailto:VKottapalli@DIRECTV.com]
> Sent: Friday, December 04, 2015 11:50 AM
> To: dev@apex.incubator.apache.org
> Subject: RE: regarding error while launching application
>
> Sorry about that, looks like the attachment is getting removed as well. I
> shall share you the stack trace.
>
> -----Original Message-----
> From: Kottapalli, Venkatesh [mailto:VKottapalli@DIRECTV.com]
> Sent: Friday, December 04, 2015 11:47 AM
> To: dev@apex.incubator.apache.org
> Subject: RE: regarding error while launching application
>
> PFA.
>
> Regards,
> Venkatesh.
>
> -----Original Message-----
> From: Sandesh Hegde [mailto:sandesh@datatorrent.com]
> Sent: Friday, December 04, 2015 11:45 AM
> To: dev@apex.incubator.apache.org
> Subject: Re: regarding error while launching application
>
> I just see blank square, can you please attach stack trace ?
>
> On Fri, Dec 4, 2015 at 11:43 AM Kottapalli, Venkatesh <
> VKottapalli@directv.com> wrote:
>
> > Hi,
> >
> >
> >
> > I have tried to launch an application which is throwing me the below
> > error.  I have checked my properties.xml for any possible issues but I
> > couldn’t find any. I don’t understand on what the actual issue is
> > looking at the stack trace, Can you help me on how to proceed in
> > identifying the root cause of this issue?
> >
> >
> >
> >
> >
> >
> >
> > Regards,
> >
> > Venkatesh.
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message