apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chandni Singh <chan...@datatorrent.com>
Subject Re: Renaming Idempotent Storage Manager
Date Mon, 16 Nov 2015 22:01:52 GMT
WindowStorageAgent was another suggestion as IdempotentStorageManager
extends StorageAgent.
If no one has any objection will call it that.

Chandni

On Sun, Nov 15, 2015 at 8:07 PM, Chandni Singh <chandni@datatorrent.com>
wrote:

> Hi,
>
> @Sandeep Will deprecate old IdempotentStorageManager. This will be a copy
> of the old one with a different name.
>
> @Sandesh
> A data store, in my opinion, is an entity which store data. This doesn't
> store data. It is used to save state per window.
>
> @Pramod
> Do you like WindowStateLogger?
>
> Thanks,
> Chandni
>
> On Nov 15, 2015 6:59 PM, "Sandeep Deshmukh" <sandeep@datatorrent.com>
> wrote:
>
>> Will there be any issue in semantic versioning because of this change?
>> On 16 Nov 2015 07:35, "Sandesh Hegde" <sandesh@datatorrent.com> wrote:
>>
>> > As it is used to store & retrieve data, just call it DataStore.
>> >
>> > On Sun, Nov 15, 2015 at 3:40 PM Pramod Immaneni <pramod@datatorrent.com
>> >
>> > wrote:
>> >
>> > > Since this is mainly for storing information pertaining to data or the
>> > data
>> > > itself how about WindowDataManager or something like that.
>> > >
>> > > On Sun, Nov 15, 2015 at 3:16 PM, Chandni Singh <
>> chandni@datatorrent.com>
>> > > wrote:
>> > >
>> > > > Hi,
>> > > >
>> > > > Received feedback from couple of folks that
>> IdempotentStorageManager is
>> > > not
>> > > > a good name for that component. It is used in some of our
>> input/output
>> > > > operator for saving per window data.
>> > > >
>> > > > I was thinking of calling it WindowLogger.
>> > > >
>> > > > Let me know if anyone has a better suggestion.
>> > > >
>> > > > Chandni
>> > > >
>> > >
>> >
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message