apex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chandni Singh <chan...@datatorrent.com>
Subject Transitive dependencies on guava
Date Thu, 22 Oct 2015 06:06:40 GMT
Hi,

I think we are tied to the guava version 11.0.2 which is used by hadoop
2.2.0

However in Malhar/contrib, I see that we have added code which depends on a
higher version- 12.0.1.
Opened MLHR-1877 to fix this.

12.0.1 came from hbase-client dependency. However I noticed that multiple
other dependencies like accumulo, solr, cassandra were also dependent on
guava and different versions.

My initial approach was to exclude guava from hbase-client but seeing that
none other dependency does it I am not sure if that will be correct.

Appreciate any input on this.

Thanks,
Chandni

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message