apex-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From t..@apache.org
Subject incubator-apex-core git commit: Bumped minimum maven version to 3.0.5. Split enforcer executions by enforced rule.
Date Thu, 29 Oct 2015 16:11:11 GMT
Repository: incubator-apex-core
Updated Branches:
  refs/heads/release-3.1 30f93e586 -> 5d7716fb2


Bumped minimum maven version to 3.0.5. Split enforcer executions by enforced rule.


Project: http://git-wip-us.apache.org/repos/asf/incubator-apex-core/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-apex-core/commit/5d7716fb
Tree: http://git-wip-us.apache.org/repos/asf/incubator-apex-core/tree/5d7716fb
Diff: http://git-wip-us.apache.org/repos/asf/incubator-apex-core/diff/5d7716fb

Branch: refs/heads/release-3.1
Commit: 5d7716fb2e2e2270a7c8580c048b550e13c853b9
Parents: 30f93e5
Author: Vlad Rozov <v.rozov@datatorrent.com>
Authored: Wed Sep 16 16:17:40 2015 -0700
Committer: Vlad Rozov <v.rozov@datatorrent.com>
Committed: Wed Oct 28 14:59:27 2015 -0700

----------------------------------------------------------------------
 pom.xml | 78 ++++++++++++++++++++++++++++++++++++++----------------------
 1 file changed, 49 insertions(+), 29 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-apex-core/blob/5d7716fb/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index 322567e..354bc28 100644
--- a/pom.xml
+++ b/pom.xml
@@ -112,35 +112,6 @@
         <version>2.1</version>
       </plugin>
       <plugin>
-        <artifactId>maven-enforcer-plugin</artifactId>
-        <version>1.4.1</version>
-        <executions>
-          <execution>
-            <id>enforce-tools</id>
-            <goals>
-              <goal>enforce</goal>
-            </goals>
-            <configuration>
-              <rules>
-                <requireJavaVersion>
-                  <version>[1.7.0,)</version>
-                </requireJavaVersion>
-                <requireMavenVersion>
-                  <version>[3.0.2,)</version>
-                </requireMavenVersion>
-                <requireReleaseDeps>
-                  <message>Snapshots are not allowed</message>
-                  <onlyWhenRelease>true</onlyWhenRelease>
-                  <excludes>
-                    <exclude>org.couchbase.mock:CouchbaseMock</exclude>
-                  </excludes>
-                </requireReleaseDeps>
-              </rules>
-            </configuration>
-          </execution>
-        </executions>
-      </plugin>
-      <plugin>
         <artifactId>maven-surefire-plugin</artifactId>
         <version>2.14.1</version>
         <dependencies>
@@ -220,6 +191,55 @@
           <artifactId>exec-maven-plugin</artifactId>
           <version>1.2.1</version>
         </plugin>
+        <plugin>
+          <groupId>org.apache.maven.plugins</groupId>
+          <artifactId>maven-enforcer-plugin</artifactId>
+          <version>1.4.1</version>
+          <executions>
+            <execution>
+              <id>enforce-java</id>
+              <goals>
+                <goal>enforce</goal>
+              </goals>
+              <configuration>
+                <rules>
+                  <requireJavaVersion>
+                    <version>[1.7.0,)</version>
+                    <message>Build requires Java 1.7 or above.</message>
+                  </requireJavaVersion>
+                </rules>
+              </configuration>
+            </execution>
+            <execution>
+              <id>enforce-maven</id>
+              <goals>
+                <goal>enforce</goal>
+              </goals>
+              <configuration>
+                <rules>
+                  <requireMavenVersion>
+                    <version>[3.0.5,)</version>
+                    <message>Build requires Maven 3.0.5 or above.</message>
+                  </requireMavenVersion>
+                </rules>
+              </configuration>
+            </execution>
+            <execution>
+              <id>enforce-release-dependencies</id>
+              <goals>
+                <goal>enforce</goal>
+              </goals>
+              <configuration>
+                <rules>
+                  <requireReleaseDeps>
+                    <message>Snapshots dependencies are not allowed for release build.</message>
+                    <onlyWhenRelease>true</onlyWhenRelease>
+                  </requireReleaseDeps>
+                </rules>
+              </configuration>
+            </execution>
+          </executions>
+        </plugin>
       </plugins>
     </pluginManagement>
     <extensions>


Mime
View raw message