any23-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guido Zuccarelli <guidozuccare...@hotmail.com>
Subject RE: Any23 core library ignores the Schema.org markup
Date Wed, 02 Jul 2014 15:34:45 GMT
It is working now, the problem was the following:
The command line tool calls the java command adding a classpath with this specific order http://pastebin.com/Q4cifgGZ

The IDEs order the imports alphabetically, I tried intelliJ idea and eclipse. 

So reordering the imports it works fine.

Date: Mon, 30 Jun 2014 14:03:54 -0400
Subject: Re: Any23 core library ignores the Schema.org markup
From: lewis.mcgibbney@gmail.com
To: user@any23.apache.org

Hi Guido
Thanks for dropping by qith your query.

On Mon, Jun 30, 2014 at 1:54 PM,  <user-digest-help@any23.apache.org> wrote:


I am having problems to get the microdata content from this document http://www.buycostumes.com/Candy-Cane-Cutie-Adult-Plus-Costume/38836/ProductDetail.aspx
.


When I make the extraction through the command line rover tool or any23 web service it works
fine. But when I try to use the Java library it completely ignores the schema.org markup.

I looked at the Rover class implementation trying to copy the use of the Any23 class and it
stills ignoring the markup.

You can see the execution result of "any23 rover http://www.buycostumes.com/Candy-Cane-Cutie-Adult-Plus-Costume/38836/ProductDetail.aspx"
here 

And also the Java code and its result


Which version of the codebase are you working from please?

I will try my best to scope this out ASAP.
Lewis 
 		 	   		  
Mime
View raw message