ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dilini Asanga <diliniasa...@gmail.com>
Subject Ant does not return after calling org.glassfish.tyrus.client.ClientManager.connectToServer()
Date Sat, 09 May 2015 09:45:14 GMT
Hi,

I have a main class which I want to run using an ant script.
(I have attached the project, which includes this main class:
WebsocketLocalClient; and the ant script I'm referring to)

This main class executes fully, when I'm running it through the command
line.

But when I run it using the ant script, it executes upto,
*System.out.println("Starting Websocket-local publisher");*

but does not execute beyond the line:
*client.connectToServer(new WebsocketLocalEndpoint(), cec, new
URI(socketServerUrl));*

Ant output is given in attachment-1.
It does not execute anything after printing the log '[java] Starting
Websocket-local publisher'

It seems that,
ant does not return after
calling org.glassfish.tyrus.client.ClientManager.connectToServer() method.

Any clues as to why this is happening?

Appreciate any help.
Thanks,
Dilini

Attachment-1:
dilini@dilini-Latitude-E6540:~/github/product-cep/modules/samples/producers/websocket-local-client$
ant
Buildfile:
/home/dilini/github/product-cep/modules/samples/producers/websocket-local-client/build.xml

init:

compile:
    [javac]
/home/dilini/github/product-cep/modules/samples/producers/websocket-local-client/build.xml:58:
warning: 'includeantruntime' was not set, defaulting to
build.sysclasspath=last; set to false for repeatable builds
     [copy] Copying 1 file to
/home/dilini/github/product-cep/modules/samples/producers/websocket-local-client/temp/classes

run:
     [echo]  Configure -Durl=xxxx -Dtopic=xxxx and (-DfilePath=xxxx and/or
-Dsn='sample number')
     [java] Starting Websocket-local publisher

Mime
View raw message