ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ed Mansky <man...@mindspring.com>
Subject Ant get-m2.xml question
Date Tue, 12 Nov 2013 14:32:36 GMT
Hi all,

I am trying to upgrade my PowerMac G4 from ant 1.6.5/JDK 1.5 to ant 
1.7.0 and am running the command:

ant -f fetch.xml -Ddest=system

to get and build dependencies for the new ant and am getting an error 
from get-m2.xml at Line #70

The error is:

Class org.apache.tools.ant.taskdefs.ConditionTask doesn't support the 
nested "typefound" element.

I have seen blog entries that indicate that error message is seen in 
Ant 1.6.x but not in Ant 1.7.x and later. Is this correct?

The fetch.xml file imports get-m2.xml which I think is installing 
needed Maven tasks in Ant. Is this correct?

I already have Maven 2.2.1 installed. Do I need to set any 
environmental variables for the Ant build to find the maven already 
installed? I have JAVA_HOME, ANT_HOME and M2_HOME all set correctly.

Finally, I see there is a Maven-Ant task project at Apache.

I downloaded that source code and tried building it but get 3 errors 
in post-build tests.

Is this maven-ant-tasks project what the comments in get-m2.xml were 
referring to?

http://maven.apache.org/ant-tasks/index.html

Do I need the build maven ant tasks first, or at all, to build a new Ant ?

Any tips or hints on these questions are greatly appreciated!

Thanks,

--Ed
-- 
E. J. Mansky II
Eikonal Research Institute
Bend, Oregon

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message