ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Matèrne (jhm) <apa...@materne.de>
Subject AW: AW: problem with ftp
Date Fri, 29 Nov 2013 07:47:48 GMT
> and i specifically stated:
> > > I have absolutely NO variables in my macrodef.

I could see that. But the error message "Syntax error in property:" make me thought that something
is wrong with properties. 


> "checkAntCommons" and "checkJakartaOro" check for the libraries that
> are required for the FTP task.  they are totally irrelevant.

If they are totally irrelevant - have you tried to strip down your build code?
Just remove the safety at the moment and delete all instructions that are not required, e.g.
availability checks of external libs, additional settings in the ftp task ...


> I'm not going to provide our whole build xml file on an open forum.  I
> provided the pieces that an experienced person will need to help me
> with this very strange issue.

While I can understand that you wont to post the whole build file.
But you asked for help and dont want to provide further information an "experienced person"
may need?


> I am running with -d.  it shows nothing, i get the debug output and
> then when it starts to send the file, it blows up complaining about a
> ${***GARBAGE*** property.
> 
> trust me the ONLY call to the <ftp/> task is the code you see below.

Then again - strip your code to the absolute minimum.
In my own maintenance script of a homepage I use

<ftp server="ftp.myserver.org" userid="user" password="password" remotedir="my/remote/dir">
    <fileset dir="source" excludes="${excludes}" includes="${includes}">
        <modified/>
    </fileset>
</ftp>


Jan

> 
> > From: apache@materne.de
> > To: user@ant.apache.org
> > Subject: AW: problem with ftp
> > Date: Fri, 29 Nov 2013 06:54:00 +0100
> >
> > My first thought is that you are setting a property with a strange
> name.
> > Could you run with "-d"? Maybe the debug output gives more hints.
> > While just reading the macrodef I couldnt find something suspect ...
> > You are calling checkAntCommons and checkJakartaOro targets. I dont
> know what happens there (or in the target from where you call
> deployHoftest).
> >
> > Jan
> >
> > > -----Ursprüngliche Nachricht-----
> > > Von: David Coleman [mailto:david_coleman_007@hotmail.com]
> > > Gesendet: Donnerstag, 28. November 2013 20:35
> > > An: user@ant.apache.org
> > > Betreff: problem with ftp
> > >
> > > hello list!
> > >
> > > I have an issue with my ftp task in ANT 1.9.1
> > >
> > > here is my ftp task:
> > >
> > >     <macrodef name="deployHoftest" description="Deploy lobby to
> > > hoftest">
> > >         <sequential>
> > >             <antcall target="checkAntCommons"/>
> > >             <antcall target="checkJakartaOro"/>
> > >             <ftp userid="dave" password="*******"
> > >                 server="164.177.*********"
> > >                 remotedir="/hoftest/assets/lobby"
> > >                 port="21"
> > >                 verbose="true"
> > >                 action="send"
> > >                 passive="yes"
> > >                 systemTypeKey="UNIX"
> > >                 >
> > >                 <fileset dir="./deploy">
> > >                     <includesfile name="deploy/Lobby.swf"/>
> > >                 </fileset>
> > >             </ftp>
> > >         </sequential>
> > >     </macrodef>
> > >     <target name="deploy" description="deploy lobby files">
> > >         <deployHoftest/>
> > >     </target>
> > >
> > > I know that i successfully connect to my server because I get a
> > > login error if i change the password, and i get my problem if i put
> > > the right password.  I also connect via filezilla all the time.  it
> > > is not an issue of concurrent connections, because i have no limit.
> > >
> > > when i run this task i get the following output:
> > > f:\var\projects\hof\svn2.------------------.com\lobby\trunk>ant
> > > deploy
> > > Buildfile: f:\var\projects\hof\svn2.-----------------
> > > .com\lobby\trunk\build.xml
> > >
> > > deploy:
> > >
> > > checkAntCommons:
> > >      [echo] checking for F:\bin\ant\lib/commons-net-1.4.1.jar
> > >      [echo] ANT commons-net library is available
> > >
> > > checkJakartaOro:
> > >      [echo] checking for F:\bin\ant\lib/jakarta-oro-2.0.8.jar
> > >      [echo] jakarta-oro library is available
> > >       [ftp] sending files
> > >
> > > BUILD FAILED
> > > f:\var\projects\hof\svn2.-----------------------
> > > .com\lobby\trunk\build.xml:324: The following error occurred while
> > > executing this line:
> > > f:\var\projects\hof\svn2.-----------------------
> > > .com\lobby\trunk\build.xml:309: Syntax error in property:
> > >
> ${☺c6W∟5⌂[6▄≈☻wä5↓╚╞K▐Bd≡6?k╥<╞:èbE▒9≡'╗î£Θ┼è├≤╘r≤?öæCu½╞╖§Σ♦ç▓(σⁿ.?
> > > n≡P ßΘéK┼♣ΣRq!╣T,ò■Ä╠W3║»æ ?√i ╩↑↓UQa{σ▼î¼≈Lpt■┼Ç☻/α┐┘D`╬!`8&├
> > >
> òƒ☺Üj▲?╔☺♦1Q.ô²¢┴┌Ça£∙▒∙Oækñcl╜vÑl^)w╠G╒╠gäêyPε╘╟7░═µu╚¡I┐N6»º4%▒ƺ≥
> > > á=⌂
> > > î5←7╚µ
> > >
> > > Total time: 3 seconds
> > >
> > > I have absolutely NO variables in my macrodef.  It appears to me
> > > that for some reason ANT is trying to parse replacements in the
> > > binary data of the file I'm trying to transfer.  I am not an ANT
> > > guru, but something here seems very very very wrong.
> > >
> > > Am I doing something wrong guys?
> > >
> > > Please help me.
> > >
> > > Thank you!
> > >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@ant.apache.org For
> additional
> > commands, e-mail: user-help@ant.apache.org
> >
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message