ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: After upgrading to ant 1.9.0 got error "Error opening zip file"
Date Thu, 18 Jul 2013 13:25:14 GMT
On 2013-07-18, Rene Groeschke wrote:

> I'm a committer on the gradle codebase. We want to update our ant
> dependencies from ant 1.8.4 to ant 1.9.0 (or better 1.9.2). One of our
> integration tests is failing after updating to ant 1.9.0:

> We're passing a jar created using ant 1.9.0 as a agent lib to a java
> process (java 1.5), the process fails with the following message:

> Error opening zip file:
> /Users/Rene/github/gradle/gradle/subprojects/plugins/src/integTest/resources/org/gradle/testing/TestEnvironmentIntegrationTest/canRunTestsWithCustomSystemClassLoaderAndJavaAgent/canRunTestsWithCustomSystemClassLoaderAndJavaAgent.jar

> Interestingly, this test is only failing with java 1.5. With java 1.6
> and java 1.7 does fine. It seems that java 1.5 is not able to use a zip
> created with ant 1.9.* as an agent.

Yes, this is a known issue.  Java5 doesn't like ZIPs with Zip64
extensions.  This has been fixed - in a way - by Ant 1.9.1 which doesn't
create ZIP64 extensions in <jar> by default anymore.

<https://issues.apache.org/bugzilla/show_bug.cgi?id=54762>

I'd recommend you go the whole way to 1.9.2 in order to fix javadoc
creation on any JDK that's not brand new, anyway.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message