ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Levy Lambert <anto...@gmx.de>
Subject Re: Need your help
Date Sun, 28 Apr 2013 01:15:21 GMT
Hello Xiaomin,

try this

when starting shell scripts from Ant, consider the shell interpreter (sh, bash, ksh) as the
executable. The path to the script file is an argument for the shell used to run the script.

so this snippet tells you what to change. Depending on your environment you might need to
change it. 

>    <exec executable="sh" spawn="true"
> vmlauncher="false">   
>        <env key="CATALINA_HOME" value="${tomcat.home}"/>   
>        <arg line="${tomcat.home}/bin/startup.sh"/>   
>      </exec>

Regards,

Antoine

On Apr 27, 2013, at 2:02 AM, xiaomin wrote:

>  First,I express my sincere gratitude for your help,as you said,I remove the
> braces {},and decompress ant again,then it is OK.But I have another problem
> and remain powerless,I hope that you can help me again.
>  I try to start Tomcat use ant in Linux OS,but I failed.Then I attempt to
> find solvent on the Internet,but got nothing.
> follow is two methods(build.xml files) that I have used,but none of them are
> successful.
> 1. <?xml version="1.0" encoding="GBK"?>
> <project name="startup_tomcat">
> <property name="tomcat.home" value="/usr/local/Ehr_linux_2.7.2"/>
> <target name="start-tomcat" description="tomcat starting.....">   
>        <exec executable="${tomcat.home}/bin/startup.sh" spawn="true"
> vmlauncher="false">   
>        <env key="CATALINA_HOME" value="${tomcat.home}"/>   
>        <arg line="-c start ${tomcat.home}/bin/startup.sh"/>   
>      </exec>
>   </target> 
> </project>
> 
> 2.<?xml version="1.0" encoding="GBK"?>
> <project name="startup_tomcat">
> <property name="tomcat.home" value="/usr/local/Ehr_linux_2.7.2/bin"/>
> <target name="startup">
> <exec dir="${tomcat.home}" executable="startup.sh">
> <arg line="-c start ${tomcat.home}/startup.sh">
> </arg>
> </exec>
> </target>
> </project>
> 
> When I run above build.xml files,it prompt :
> "Buildfile: /usr/local/rhio/apache-ant-1.9.0/case/build.xml
> BUILD SUCCESSFUL
> Total time: 0 seconds" 
> but Tomcat haven't been started,I don't know how to do it,can you help me.
> Thank you very much!
> 
> 
> 
> 
> --
> View this message in context: http://ant.1045680.n5.nabble.com/Need-your-help-tp5714084p5714091.html
> Sent from the Ant - Users mailing list archive at Nabble.com.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message