ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Java 5 fails to run jar files created with Ant 1.9.0
Date Thu, 28 Mar 2013 11:59:04 GMT
On 2013-03-28, Marc Benstein wrote:

> Java 5 fails to execute jars created with Ant 1.9.0. Java 6 and 7 work
> fine to execute the jar.

I assume creating the same jar with Ant 1.8.x works just fne for you.

Ant 1.9.0 ships with a zip package that has some enhancements over the
one in 1.8.x - Zip64 support in particular.  It is possible Ant now
creates jars by default that Java5 doesn't like.

> The message I am seeing in Java 5 is "Invalid or corrupt jarfile"

Is there any sort of additional information?  You say jar -tf doesn't
complain.  Do you only get the error when you use java -jar or also when
you add the jar to the classpath and execute your main class explicitly?

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message