ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KARR, DAVID" <dk0...@att.com>
Subject Why is javac for unit tests working for me, but not someone else?
Date Fri, 15 Feb 2013 23:21:02 GMT
I implemented a target in a base build script for compiling and running unit tests with cobertura.
 It's working fine in my environment.  Someone I work with is trying to use it in their environment.
 As expected, it bombs completely in his environment.  I'm trying to find some clues that
tell me what might be wrong.

I'm using Ant 1.7.1 and JDK 1.6.0_30, and he's using Ant 1.7.0 and JDK 1.6.0_35.

I've run "ant -v" in both environments and compared the output.

The build eventually gets to a target I've named "compile-unit-test".

In my environment, this proceeds to compile the unit test classes.  In the other environment,
I see this:

...\build.xml:636: gen/test/classes is not a legal value for this attribute
	at org.apache.tools.ant.types.EnumeratedAttribute.setValue(EnumeratedAttribute.java:94)
	at org.apache.tools.ant.IntrospectionHelper$8.set(IntrospectionHelper.java:1004)
	at org.apache.tools.ant.IntrospectionHelper.setAttribute(IntrospectionHelper.java:400)
	at org.apache.tools.ant.RuntimeConfigurable.maybeConfigure(RuntimeConfigurable.java:392)
	at org.apache.tools.ant.RuntimeConfigurable.maybeConfigure(RuntimeConfigurable.java:349)
	at org.apache.tools.ant.UnknownElement.handleChild(UnknownElement.java:565)
	at org.apache.tools.ant.UnknownElement.handleChildren(UnknownElement.java:343)
	at org.apache.tools.ant.UnknownElement.configure(UnknownElement.java:198)
	at org.apache.tools.ant.UnknownElement.maybeConfigure(UnknownElement.java:160)
	at org.apache.tools.ant.Task.perform(Task.java:347)

The following is the "compile-unit-test" target:

<target name="compile-unit-test" depends="init">
        <property name="testbuildclasspath" refid="testbuild.classpath" />
        <mkdir dir="${test.classes.dir}"/>
        <javac srcdir="${test.src.dir}" 
            destdir="${test.classes.dir}" 
            includes="**/*Test.java" 
            debug="on" 
            optimize="off">
            <classpath refid="testbuild.classpath"/>
        </javac>
        <copy todir="${test.config.dir}" preservelastmodified="${copy.preserve}">
            <fileset dir="${test.resources.dir}">
                <include name="**/*.properties"/>
            </fileset>
        </copy>
	</target>

The value of the "test.classes.dir" is "gen/test/classes".

What might be going wrong here?

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message