ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From S T <>
Subject Re: Does work with Ant 8.1.2?
Date Thu, 01 Nov 2012 08:11:07 GMT
S T <testers3n3 <at>> writes:

> Morning.
> I'm using:
>   Apache Ant(TM) version 1.8.2 compiled on December 20 2010
> and it seems that the system property might be not
> taken into account by Ant.
> I specify it on the command line, alongside the appropriate password
> specification, expecting that it'll help the GET task retrieving a resource
> via HTTPS. However
> a keeps being
> reported, even though I'm sure the keystore and the password used are
> valid. Hence my question.
> Thanks,
> --Christian


The issue I reported below was a user error. The JSSE properties
(, etc) have to be  passed to Java, not Ant.

This means that they have to be specified in the ANT_OPTS environment 
variable rather than as properties specified using the -D option on
Ant's command line.

All this is (implicitly) explained in the Environment Variables sub-section
of the Running Apache Ant section in the manual.

Sorry for the white noise,

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message