ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Tabak <michael_ta...@yahoo.com>
Subject compilearg
Date Mon, 18 Jun 2012 01:43:46 GMT
I'm running Ant 1.8.2. I have a line in my build file to override the destination directory:
   

  <target name="compile">
        <javac includeantruntime="false" 
               srcdir="${src}" 
               destdir="${build}" >  
               <compilerarg compiler="modern" value="-d output1.6" />
        </javac>
     </target>


This is in my compile target. If I replace "-d output1.6" with -version or  -verbose, the
command works, but if I use
something like -cp . or -d output I get  a "[javac] invalid flag: -d output1.6" and the build
fails.

Thank you

 
==================================================================================
"He who joyfully marches in rank and file has already earned my contempt. He has been given
a large brain by mistake, since for him the spinal cord would suffice."
A. Einstein
==================================================================================
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message