ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Fetzer <elstonk...@yahoo.com>
Subject Build directly on machine vs. SSH to machine and start build
Date Mon, 07 May 2012 19:12:01 GMT
This is very strange to me.  Here are the 2 scenarios.
 
Scenario 1:
1)  Log on to buildMachine as user builduser
2)  >bash
3)  >cd /my/builddir
3)  >/opt/apache-ant-1.7.1/bin/ant -f build.xml -Dfull.buildnumber=3.0.2.8
4)  Build succeeds without issue
 
Scenario 2:
1)  From a different machine:
        >ssh -f builduser@buildMachine ". ~/.bash_profile;cd /app/rosstr/build;/opt/apache-ant-1.7.1/bin/ant
-f build.xml -Dfull.buildnumber=3.0.2.8
2)  There are 7 different apps that get built in the build.xml file.  Each get called by
the ant task.  Only one of them fails with no indication as to why it failed.
 
I've tried loads of stuff.  I echo just before it hits the ant call and the echo outputs. 
I've retyped the ant line several times without success.  I've changed the order of this
particular ant call and it doesn't matter, it fails when it gets to it.  Here's the code
that crashes:
 
      <ant antfile="BuildReports.xml"/>
 
Not exactly a tough thing to do.  Call the BuildReports.xml file in the current directory... 
Anyone have any idea what this could be or what I could do to debug this?  There is no verbose=true
on the ant task...
 
Thanks,
Eric
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message