ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lokesh Jain <lokesh.j...@in.fiorano.com>
Subject Incorrect reading of property containing accented chars from build.properties by custom task
Date Sat, 21 Apr 2012 08:01:15 GMT
Hi,

I have a custom ant task which reads certain properties from 
build.properties and exports applications based on that.

<target name="exportSingleApp_internal" >
<taskdef classname="com.xxx.yyy.ant.tasks.ExportApplication" 
name="exportApplication" classpathref="proj.lib"/>
<exportApplication applicationID = "${APPLICATION_GUID}" 
applicationVersion="${APPLICATION_VERSION}"
                           exportLocation="${APPLICATION_EXPORT_DIR}"/>
</target>

The property APPLICATION_GUID contains some accented chars such as  "ÀÁÂ".

Now, when i execute this task on a Windows box, it seems to be working fine.

But on a CentOS box, the same property is read by the task program along 
with some junk unicode chars. Consequently, the strings do not match 
which affects some of the internal logic of the ant task.

Eg: If I set the APPLICATION_GUID property to HELLOÀÁÂ
The java program of the task reads the property as 
HELLOÃ\u0080Ã\u0081Ã\u0082

The $LANG env var on CentOS box is set to en_US.UTF-8.

I am not sure if this is an Ant issue. Any pointers would be helpful.

Regards,
Lokesh

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message