ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Trouble building using bcel
Date Sat, 03 Mar 2012 04:54:06 GMT
On 2012-03-02, Jacob Silterra wrote:

> If I place ant-apache-bcel-1.6.5.jar in ~/.ant/lib, everything builds
> fine.  I can't find any documentation on this file, though, just
> gleaned it from googling and downloaded from jarfinder, I couldn't
> find an official download site.

Ant 1.6.5 is old, very old.  1.8.3 is the current version.  You can
download Ant from <http://ant.apache.org/bindownload.cgi> and old
releases from <http://archive.apache.org/dist/ant/binaries/>.

Ant comes with several jars, split up between classes that depend on
third party libraries to work.  The file ant-apache-bcel-1.6.5.jar is
the jar containing all classes inside of Ant that require Apache BCEL,
there is a similar file in every binary distribution of Ant.

> It seems like bcel-5.2.jar should be defining the <classfileset> tag,
> but somehow it isn't being defined properly. Is there a possibility of
> a path conflict?

The class behind classfileset is defined in ant-apache-bcel.jar and
requires classes from bcel-5.2.jar - so you need both jars.

> This is the error mesage:
> Unable to load dependency analyzer:
> org.apache.tools.ant.util.depend.bcel.FullAnalyzer

> Platform:
> Mac OS X 10.7
> Apache Ant(TM) version 1.8.2 compiled on October 14 2011
> Using bcel-5.2.jar, in ~/.ant/lib and also /usr/share/ant/lib

Is this a system installed Ant?  There may be an additional package for
optional tasks that didn't install.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message