ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knuplesch, Jürgen <Juergen.Knuple...@icongmbh.de>
Subject AW: Compiler Versionl question
Date Thu, 29 Mar 2012 06:53:33 GMT
In the run configuration in Eclipse you need to check and probably adapt the Java version.

You can use several Java VMs together witzh Eclipse, so you need to configure which one to
use together with your ANT job.
By default the default JRE from Eclipse is used.

-----Ursprüngliche Nachricht-----
Von: Rhino [mailto:rhino1@sympatico.ca] 
Gesendet: Mittwoch, 28. März 2012 19:27
An: ant-user
Betreff: Compiler Versionl question

I'm getting several messages like this when doing an javac task using Ant 1.8.2 in Eclipse
3.7. I'm running on Windows XP SP3 and my source value is set to 1.6.

  [javac] warning: c:\eclipse\workspace\Foo\bin\com\example\Foo.class: 
major version 51 is newer than 50, the highest major version supported by this compiler.
        [javac] It is recommended that the compiler be upgraded.

Am I right in believing that I need to upgrade the Ant version in Eclipse to resolve this
problem? If that's not the correct resolution, what should I do? I tried changing the source
value to 1.7 but that didn't work.

I haven't done much with Ant in the last year or two so my memory is a bit foggy on how to
handle this issue....
--
Rhino

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message