ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knuplesch, Juergen" <Juergen.Knuple...@icongmbh.de>
Subject AW: fork, JUnit and Linux
Date Mon, 14 Nov 2011 15:09:57 GMT
I use OpenSuse 11.4 32 Bit
I use Java 1.6.0.17, JDK from Sun
Before that I tried 1.6.022 and OpenJDK.

The problem I have is when I use the fork attribute.

Do I have to tell Linux to take the old classpath along. How?
With windows it works the way I use it.

In the moment I do not use fork anymore and everything is working.
But I would like to use fork but I do not see where the problem is and how to solve it.


-----Urspr√ľngliche Nachricht-----
Von: Stefan Bodewig [mailto:bodewig@apache.org] 
Gesendet: Freitag, 11. November 2011 15:58
An: user@ant.apache.org
Betreff: Re: fork, JUnit and Linux

On 2011-11-09, Knuplesch, Juergen wrote:

> when I run a <junit> task with

> fork="yes"

> under LINUX the test does not even start:

LINUX is a pretty broad term here.  Which version of java are you using?
I use Ant on Linux using OpenJDK or Sun's Java without any problems.
If this is gcj then you may have quite a bit of work to do to make thigs
run correctly.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message