ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Radek Simcik <radek.sim...@gmail.com>
Subject Exec on Windows is not fired if ant started from sinatra
Date Wed, 03 Aug 2011 07:16:01 GMT
Hi

I run ant from sinatra http://www.sinatrarb.com/ on Windows XP

When there was one target (not exec) everything worked fine.

Now I added new target with exec. I run another ruby script from
there. Now the tricky part comes.... I run ant from command line or
.bat or simple (not sinatra) rb file everything works fine. If I run
the same code from sinatra ruby file the target is fired but ant hang
at the exec tag.

ant -v gives me


aftertaf:
    [exec] Current OS is Windows XP
    [exec] Executing 'C:\Ruby187\bin\ruby.exe' with arguments:
    [exec] 'C:\EduTester\others\afterant.rb'
    [exec] 'update_latest'
    [exec] '10.0.0.50:4567'
    [exec] 'basics'
    [exec] 'login'
    [exec] '20110803163704'
    [exec]
    [exec] The ' characters around the executable and arguments are
    [exec] not part of the command.
Terminate batch job (Y/N)? y

I have to terminate ant when -v used. Is that correct ant behaviour?

My ant target in question looks like

<target name="aftertaf" depends="taf" description="after TAF ruby stuff">
  <exec executable="ruby.exe">
    <arg line="C:\EduTester\others\afterant.rb update_latest
10.0.0.50:4567 basics login 20110803111432"/>
  </exec>
</target>

I also tried `arg value` instead of 'arg line' with the same result.



I crated a question on SO with more details
http://stackoverflow.com/questions/6920418/x-never-finishes-ant-or-sinatra-or-windows-causing-it

Is there any way I can make the exec work?

Thank you

Radek

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message