ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob J <...@dcsportbikes.net>
Subject Re: Question regarding UTF-8 and property files
Date Fri, 27 May 2011 18:46:35 GMT
Ahhh, did some digging and figured it out!

Apple OSX's java interpreter's default charset is MacRoman

I modified bin/ant to add -Dfile.encoding=UTF-8 as an argument for the java
interpreter, and it works fine now:

hitman@bigdog ~/t/t/apache-ant-1.8.2$ bin/ant foo2
Buildfile: /Users/hitman/t/t/apache-ant-1.8.2/build.xml

foo2:
     [echo] [Test ế]

BUILD SUCCESSFUL
Total time: 0 seconds

thanks for all the help, all!

thanks,
rob

On Fri, 27 May 2011, Rob J wrote:

> On Fri, 27 May 2011, Scot P. Floess wrote:
> 
> > Works for me:
> > 
> > <?xml version="1.0" encoding="utf-8"?>
> > <project name="test" default="foo">
> >     <target name="foo">
> >         <loadproperties srcFile="foo.properties" encoding="iso-8859-1"/>
> >         <echo message="[${foo.property}]"/>
> >         <echo file="test.txt" message="${foo.property}"/>
> >     </target>
> > </project>
> > 
> 
> Hmm.  Yup.  I actually just went to a linux system and ran the exact same
> example using the exact same ant version and it works fine over there.  The
> linux box is using the Sun java6 JRE.
> 
> The system that is failing is a OSX box with ant installed.
> 
> It is obviously some issue with Apple's installed java interpreter.
> 
> Can you think of anything that might be an issue here?  Perhaps some java
> setting that is different between the OSX box and the Debian linux box?
> 
> thanks,
> rob

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message