ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sam Wootton <sam.woot...@gmail.com>
Subject Re: Invalid implementation Error
Date Sun, 13 Mar 2011 14:49:02 GMT
HI,

thanks for your help.  i understand what you're saying about it being a
standalone system.  i guess its a mixture of "well, this SHOULD work... its
a new system", and the fact that i've had problems before, when ignoring the
Yast package manager (albeit for a webserver, not just a build tool... but
still).

So, what you're saying is, that a new, direct, download of ant, will have
this jar and therefore not complain about missing classes.

i think we've established that its not an obvious configuration issue i've
missed.

many thanks. i'll investigate and contact opensuse if it is the case that
ant doesnt have all dependencies in the initial pkg download.

Regards, Sam


On 13 March 2011 14:41, Michael Ludwig <milu71@gmx.de> wrote:

> Sam Wootton schrieb am 13.03.2011 um 12:53 (+0000):
> >
> > Michael , i think with opensuse its a bad idea to ignore the
> > repository / software management way of downloading and installing
> > software.  the system can get in a real mess.  its far better to let
> > it put the software where it wants to.
>
> I don't see that danger at all given that Ant is pure Java software,
> without any dependencies on system libraries such as libc and friends.
>
> But it's your system, of course. :-)
>
> I'd then verify the error is from a pristine OpenSuse package and
> then report the error to OpenSuse.
>
> Good luck,
>
> Michael
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message