ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mohan <mohan...@gmail.com>
Subject Re: project.createTask() not working with ant-1.8.2
Date Tue, 15 Feb 2011 13:11:52 GMT

>> One thing to look out for apart from the obvious CLASSPATH environment
variable, ${ANT_HOME}/lib and ~/.ant/lib is the shell script you use to
launch Ant (I assume a Unix like system from ant.jar's path in your
error message). 

* I do not have the CLASSPATH variable set.  I also do not have the .ant
directory in my home directory.  But ANT_HOME is set to Ant 1.8.2.

* I'm not using any wrapper script for ant invocation. I'm invoking the ant
script directly from Ant-1.8.2/bin/ant as shown in the second update.

>> The most likely reason you see this error is that your Java VM has
loaded a different version of ant.jar

How can I check which version of ant.jar is getting loaded with the JVM?

I tried printing the command that is being executed in the Ant wrapper
script and it is:

exec "/usr/local/java/jdk/jre/bin/java" -classpath
"/prod/tools/infra/apache/ant-1.8.2/lib/ant-launcher.jar"
-Dant.home="/prod/tools/infra/apache/ant-1.8.2"
-Dant.library.dir="/prod/tools/infra/apache/ant-1.8.2/lib"
org.apache.tools.ant.launch.Launcher -cp ""

I do not see any other version of ant being loaded in this command.  Could
you let me know if I'm missing something?


Thanks,
Mohan.



-- 
View this message in context: http://ant.1045680.n5.nabble.com/project-createTask-not-working-with-ant-1-8-2-tp3385716p3385921.html
Sent from the Ant - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message